problems with Epson TM-U220b

General discussions about Abacre Restaurant Point of Sale
Post Reply
ITF
Posts: 2
Joined: Sun Feb 18, 2007 11:14 pm

problems with Epson TM-U220b

Post by ITF » Sun Feb 18, 2007 11:33 pm

I'm having problems with the EPSON Receipt Printer TM-U220B. MAybe I need the right drivers, or I'm installing it wrong. The printer is recognized by the Operating System but as TM-U220 without the B, does that affect anything?

Also, my OS Specs are Win XP, Abacre 2.0

When I try to do a "Print Bill" test in Abacre it says that the "print job" went through and there isn't an error, but the Receipt printer didn't print anything.


If anyone has the drivers or instructions for me that'd be great!

I'd like to know if this is a printer problem, or abacre problem... Well I'd just like to know what's the problem and how it can be fixed. :oops:

As far as I know, it's (the printer) is recognized, there's no print error, but it just doesn't print.

Abacre
Site Admin
Posts: 1201
Joined: Mon Jan 31, 2005 5:32 pm
Contact:

Post by Abacre » Tue Feb 20, 2007 10:49 pm

It depends on answers on many questions:
Did you install OPOS drivers on your printer?
In ARPOS do you use OPOS drivers or Windows drivers to work with
printer? Please verify it: go to main menu - Configuration - Bill
Configuration - Printer.

Therefore in general there are two methods to work with EPSON and
other printers:
1. Via OPOS drivers.
2. Via Windows drivers.

The best method is to use the OPOS drivers.

Please read step-by-step instructions:
http://www.abacre.com/restaurantpos/man ... driver.htm
There are two major steps:
1. you should download and install CCO OPOS drivers
AND
2. install OPOS drivers provided by EPSON.

Then you have to check your printer with Epson SetupPOS utility.
This utility is usually installed with OPOS drivers from Epson.
Otherwise you can always download it from Epson's web site.

Start Epson SetupPOS utility. On Left tree click on Device -
POSPrinter - then right click on your printer and execute CheckHealth
interactive command.
This CheckHealth command should successfully run with your printer. It
means that your printers is correctly installed and it can be used
with other POS programs.

Normally only after that you should start ARPOS and go to main menu -
Configuration - Bill Configuration - Printer where you have to select
OPOS as connection method and specify LDN (logical device name) of
your printer that you see in Epson SetupPOS utility.

Therefore the recommending way is to use the OPOS drivers.

The second variant: use Windows drivers. Go to main menu -
Configuration - Bill Configuration - Printer and select Windows
driver as connection method. Again it's better to use Windows drivers
installed from Epson's CD than standard Windows drivers. If it does
not work with Windows drivers you can also use an alternative printing
module which uses Windows drivers in alternative way: go to main menu
- Configuration - Bill Configuration - Parameters and check "Use
alternative printing module".
Kind regards,
Abacre Limited
http://www.abacre.com
support@abacre.com

ITF
Posts: 2
Joined: Sun Feb 18, 2007 11:14 pm

Post by ITF » Fri Feb 23, 2007 11:36 pm

OK, I tried the OPOS instructions and same results. No reaction, nothing.

When I do the CheckHealth Interactive I get an error.
Here's the error I get, maybe this is what's stopping it.

------------------------
Error occurred in calling the CheckHealth MEthod:

Claim(5000) = 106 (0x0000006a)
ResultCodeExtended = 10007 (0x00002717)




I might get a new POS Printer soon, but out of curiousity I'd really like to know what's wrong with this one.

Thanks.

Abacre
Site Admin
Posts: 1201
Joined: Mon Jan 31, 2005 5:32 pm
Contact:

Post by Abacre » Sat Feb 24, 2007 12:29 am

I think it's clear now that it's the problem on Epson's side. So the
normal way is to contact Epson's support and provide this the error
code. Maybe you can search for this error code on google.

It maybe some trivial: like you did not install the latest drivers or
you used the wrong/damaged cable or similar things.
Kind regards,
Abacre Limited
http://www.abacre.com
support@abacre.com

jasmeen
Posts: 1
Joined: Sat Feb 20, 2016 12:05 pm

Re: problems with Epson TM-U220b

Post by jasmeen » Sat Feb 20, 2016 12:13 pm

When I try to do a "Print Bill" test in Abacre it says that the "print job" went through and there isn't an error, but the Receipt printer didn't print anything.
== Chess ==

Abacre
Site Admin
Posts: 1201
Joined: Mon Jan 31, 2005 5:32 pm
Contact:

Re: problems with Epson TM-U220b

Post by Abacre » Wed Feb 24, 2016 8:17 pm

It's a printer spooling problem.
Go to menu Configuration - Bill Configuration - Parameters.
check Use Alternative Printing module.
restart the program.
if it does not work then
Go to menu Configuration - Bill Configuration - Parameters.
uncheck Use Alternative Printing module.
check Use HTML printing module.
restart the program.
Kind regards,
Abacre Limited
http://www.abacre.com
support@abacre.com

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests