Page 1 of 1

Unable to Print to Remote Printer After Upgrade

Posted: Tue May 16, 2006 2:01 am
by Waygate
Hi Roman,

After taking you advise to upgrade to for the close order button i noticed both machines are now unable to print to the remote printer. The remote printer is an EPSON TM-T88II w/ a Netgear PS101 Print Server Parallel 1 Port. Once i installed the upgrade i ran ARPOS and tried printing to the kitchen and what came out was characters i did not recogize. I checked my printer drivers >the driver is is set to "Generic Printer Driver" which worked great before the upgrade. I uninstalled the drivers & reinstalled and still receiving what looks like high end ASCI characters printing out. I also tried using the EPD Advance Printer Drivers with the same results. Does the upgrade effect current print mappings and or current drivers? If so, what can i do to restore the kicthen printer to print in legible format. My client is now without a kitchen printer and will hand writting orders to the kitchen for the time being. Please help!

Posted: Tue May 16, 2006 6:46 am
by Abacre
We changed our printing module in the latest version.
We will provide you solution soon.
What can you try now: use OPOS drivers instead of Windows drivers.
Read here: ... driver.htm

Posted: Fri May 19, 2006 4:20 pm
by Waygate
Hi Roman,

Thank you for your prompt response. I am in a situation where i am trying to put a band aid fix for a very big leak. The restaurant owner is wanting to know when his kitchen printer will be available since it was used for every single order. Since reading your post, i instructed the waitstaff that i configured both machines to print locally for kicthen requests. Surely you know that OPOS drivers are only good for local printing and not configurable to IP addresses. I am dire need the new print module to work across network print mappings.

My questions, when will the fix for this be available? If it will be more than a week from today, can i revert back to the last build to restore print capabilities to at least the (machine1) waitstaff machine? If i revert back to an earlier build will it have issues with the new build for the 2nd machine?I am waiting for your response. Thanks.


Posted: Fri May 19, 2006 4:33 pm
by Abacre
For now we advise you to use existing DB file with previous build
which you have. Once fixed you may always use the existing DB file
with new build.

We will contact you by email to make some tests. Because it looks like
new printing module works fine on some printers and it does not work
on others.

Posted: Fri May 19, 2006 6:17 pm
by Waygate
i have received your printertest app. Here are the results.

Device: \\LPTN\P1
Page size in pixels: width: 5100, height: 6600
Page size in 10s mm: width: 2159, height: 2794, size: 1
DefaultSource: 15
Supported fonts:
Device Font 10cpi
Device Font 12cpi
Device Font 17cpi

Test Page from the \\LPTN\P1 web interface is fine but when its ran in ARPOS i would get characters like

*TF-BFTWR-U a * A ET * b - R C E
i A - l k n * tC
H C * -
H B 1 sE -

This would print in about a foot of receipt paper.


Posted: Thu Jun 01, 2006 2:59 pm
by Waygate
Hi Roman,

Do you have any updates? I have tried all the settings, configurations & drivers for this with the same results. Please advise. Thanks.

Posted: Mon Jun 12, 2006 5:07 am
by Waygate
I have been deligently checking this forum for the past 3 and a half weeks & also emailed you w/ no response. I understand that it takes time to test and develop your product but this is a crucial piece of functionality in ARPOS that cannot be ignored any longer since the remote printer is what prints to the kitchen. I don't know else to say but i need this fix ASAP. Thank you for your advance consideration. Please respond.

PS. I also tried to switch out to a different thermal printer model like the EPSON TM-T88III USB with the same results below.

Posted: Tue Jun 20, 2006 2:57 am
by Waygate
Another week passes by without any type of reply or email addressing common problems in this board. What's going on Roman?

Posted: Mon Jul 03, 2006 5:15 pm
by Abacre
The issue has been corrected.
Download the updated version from the following location:
Install it over existing version. It will update needed files.
Then go to main menu - Configuration - Bill Preferences (for bill
printer) or Notification Printers - Options - Parameters -
check Use Alternative Printing Module parameter. So it will print
using old printing module.