8 Files. Replaces in 4, not in other 4

General discussions about Advanced Find and Replace
Post Reply
pmaugust

8 Files. Replaces in 4, not in other 4

Post by pmaugust » Mon Jan 31, 2005 5:32 pm

Hi,
I have 8 files in a directory (3 *.bat, 1 *.txt, 4 *.wme). When I run a batch replace with a mask of *.* and changes such as:
replace #C# with 3
replace #P# with 2
replace #Q1# with 7
replace #TITLE# with This is the title
it successfully updates the bat and txt files, but does not update the wme files. Status indicates :
show's the 4 bat and txt files with updates. Does not list the wme files (which have matching character strings).
Status message is: "Found 4 files of 8 in 2 sec, 687 msecs."
The wme file is an XML formatted input file for windows media encoder. It's just text. Any reason why this isnt working?

Thanks in Advance,
Paul

Abacre
Site Admin
Posts: 1198
Joined: Mon Jan 31, 2005 5:32 pm
Contact:

Re: 8 Files. Replaces in 4, not in other 4

Post by Abacre » Mon Jan 31, 2005 5:32 pm

pmaugust wrote:Hi,
I have 8 files in a directory (3 *.bat, 1 *.txt, 4 *.wme).
The wme file is an XML formatted input file for windows media encoder. It's just text. Any reason why this isnt working?

Thanks in Advance,
Paul


Hi,

In Mask field you should add *.wme.

Roman

pmaugust

Still not working

Post by pmaugust » Mon Jan 31, 2005 5:32 pm

Roman,

I used mask *.* (and tried *.wme), but still could not make it work. Using the batch process. Below is one of the wme files and the cfg I am using. Maybe you can figure out what I don't have correct?

Thanks,
Paul

PostGame.cfg
========================START
CaseSensWords=false
CaseSensPhrases=false
Limit=100
Limited=false
SortByFound=true
ConfirmBeforeReplace=true
ConfirmBeforeBR=false
KeepOriginalFileDate=false
SFont=0;0;Verdana;0;10;
SaveAsUnixFiles=false
DeleteCRLF=true
SaveAsUnixFilesBR=false
SearchSubFolders=false
ShowFileDesc=true
ClearTextFields=false
ClearSearchQuery=false
ShowHelpButton=true
MinimizeToTray=false
Methods_Height=286
RFindText_Height=113
EndWith_Height=69
Left=461
Top=83
Height=742
Width=819
Normal=true
ShowMessageNoWord=true
ShowMessageNoExcel=true
ShowMessageNorton=true
ShowMessageFileDamaged=true
ShowMessageReadOnly=true
ShowMessageFileOpened=true
ActivePage=2
FCaseSens=false
RCaseSens=false
BRCaseSens=false
FWholeWordsOnly=false
RWholeWordsOnly=false
BRWholeWordsOnly=false
FOfficeFiles=false
ROfficeFiles=true
BROfficeFiles=true
RUseAdvOpts=false
BRUseAdvOpts=false
BRUseRegExpr=false
BRJustFind=false
LineByLine=false
ModifierS=false
ModifierM=true
ModifierI=true
ModifierG=false
ModifierX=false
MaskText=*.wme
Mask=*.wme
Mask=*.*
Mask=*.doc;*.xls;*.htm;*.html;*.asp;*.txt;*.php
Mask=*.htm;*.html;*.asp;*.txt;*.php
Mask=*.doc;*.xls
Mask=*.txt
PathText=E:\THSFootball\PostGameFiles\WorkFiles
Path=E:\THSFootball\PostGameFiles\WorkFiles
Path=C:\Program Files\Advanced Find and Replace\Samples
QueryText=+Enjoy -download "Abacre"
Query=+Enjoy -download "Abacre"
QFont=0;0;Verdana;0;10;
BRFont=0;0;Verdana;0;8;
ActType=0
RFindText=
RFindText=Enjoy using our software!
Replace=Kind Regards,
Replace=Abacre Corporation
QueryType=0
AdvOpts=true
DateCond=0
Period=3
DatePeriod=2
SizeCond=-1
Size=100
SizeType=1
FNameLengthCond=-1
FNameLength=10
Col0=150
Col1=179
Col2=50
Col3=57
Col4=50
Col5=50
SearchFor=#C#
ReplaceWith=3
SearchFor=#P#
ReplaceWith=2
SearchFor=#Q1#
ReplaceWith=21
SearchFor=#Q2#
ReplaceWith=6
SearchFor=#Q3#
ReplaceWith=0
SearchFor=#Q4#
ReplaceWith=7
SearchFor=#Q5#
ReplaceWith=0
SearchFor=#OQ1#
ReplaceWith=0
SearchFor=#OQ2#
ReplaceWith=0
SearchFor=#OQ3#
ReplaceWith=0
SearchFor=#OQ4#
ReplaceWith=0
SearchFor=#OQ5#
ReplaceWith=0
SearchFor=#OT#
ReplaceWith=n
SearchFor=#TITLE#
ReplaceWith=Tigard vs McMinnville - 09/17/2004
SearchFor=#DIR#
ReplaceWith=McMinnville
SearchForWidth=228
ReplaceWithWidth=457
========================END

encodeQ1.wme
========================START
<?xml version="1.0"?>

<WMEncoder major_version="9"
minor_version="0"
Name="WMEncoder17993"
SynchroniesOperation="0" >
<Description Author="www.tigardfootball.com"
Title="#TITLE#"
Copyright="www.tigardfootball.com"
Description="1st Quarter" />
<SourceGroups >
<SourceGroup Name="Convert" >
<Source Type="WMENC_VIDEO"
Scheme="file"
InputSource="F:\Build\#DIR#\G#C#Q1.avi"
PreProcesses="1" >
<UserData >
</UserData>

</Source>

<Source Type="WMENC_AUDIO"
Scheme="file"
InputSource="F:\Build\#DIR#\G#C#Q1.avi"
PreProcesses="1" >
<UserData >
</UserData>

</Source>

<EncoderProfile id="Multiple bit rates audio (CBR) / Multiple bit rates video (CBR)" />
<UserData >
</UserData>

</SourceGroup>

</SourceGroups>

<File LocalFileName="E:\WMRoot\THSFB\G#C#Q1.wmv" />
<WMEncoder_Profile id="Multiple bit rates audio (CBR) / Multiple bit rates video (CBR)" >
<![CDATA[ <profile version="589824"
storageformat="1"
name="Multiple bit rates audio (CBR) / Multiple bit rates video (CBR)"
description="">
<streamconfig majortype="{73647561-0000-0010-8000-00AA00389B71}"
streamnumber="1"
streamname="Audio Stream"
inputname="Audio409"
bitrate="32000"
bufferwindow="5000"
reliabletransport="0"
decodercomplexity=""
rfc1766langid="en-us"
>
<wmmediatype subtype="{00000161-0000-0010-8000-00AA00389B71}"
bfixedsizesamples="1"
btemporalcompression="0"
lsamplesize="768">
<waveformatex wFormatTag="353"
nChannels="2"
nSamplesPerSec="32000"
nAvgBytesPerSec="4000"
nBlockAlign="768"
wBitsPerSample="16"
codecdata="008800001700001E0000"/>
</wmmediatype>
</streamconfig>
<streamconfig majortype="{73647561-0000-0010-8000-00AA00389B71}"
streamnumber="2"
streamname="Audio Stream"
inputname="Audio409"
bitrate="16000"
bufferwindow="5000"
reliabletransport="0"
decodercomplexity=""
rfc1766langid="en-us"
>
<wmmediatype subtype="{00000161-0000-0010-8000-00AA00389B71}"
bfixedsizesamples="1"
btemporalcompression="0"
lsamplesize="640">
<waveformatex wFormatTag="353"
nChannels="2"
nSamplesPerSec="16000"
nAvgBytesPerSec="2000"
nBlockAlign="640"
wBitsPerSample="16"
codecdata="002200002E0080070000"/>
</wmmediatype>
</streamconfig>
<streamconfig majortype="{73647561-0000-0010-8000-00AA00389B71}"
streamnumber="3"
streamname="Audio Stream"
inputname="Audio409"
bitrate="10000"
bufferwindow="5000"
reliabletransport="0"
decodercomplexity=""
rfc1766langid="en-us"
>
<wmmediatype subtype="{00000161-0000-0010-8000-00AA00389B71}"
bfixedsizesamples="1"
btemporalcompression="0"
lsamplesize="400">
<waveformatex wFormatTag="353"
nChannels="1"
nSamplesPerSec="16000"
nAvgBytesPerSec="1250"
nBlockAlign="400"
wBitsPerSample="16"
codecdata="002200002600B0040000"/>
</wmmediatype>
</streamconfig>
<streamconfig majortype="{73647561-0000-0010-8000-00AA00389B71}"
streamnumber="4"
streamname="Audio Stream"
inputname="Audio409"
bitrate="8000"
bufferwindow="5000"
reliabletransport="0"
decodercomplexity=""
rfc1766langid="en-us"
>
<wmmediatype subtype="{00000161-0000-0010-8000-00AA00389B71}"
bfixedsizesamples="1"
btemporalcompression="0"
lsamplesize="320">
<waveformatex wFormatTag="353"
nChannels="1"
nSamplesPerSec="8000"
nAvgBytesPerSec="1000"
nBlockAlign="320"
wBitsPerSample="16"
codecdata="00220000260080070000"/>
</wmmediatype>
</streamconfig>
<streamconfig majortype="{73646976-0000-0010-8000-00AA00389B71}"
streamnumber="5"
streamname="Video Stream"
inputname="Video409"
bitrate="241000"
bufferwindow="5000"
reliabletransport="0"
decodercomplexity="AU"
rfc1766langid="en-us"
>
<videomediaprops maxkeyframespacing="80000000"
quality="60"/>
<wmmediatype subtype="{33564D57-0000-0010-8000-00AA00389B71}"
bfixedsizesamples="0"
btemporalcompression="1"
lsamplesize="0">
<videoinfoheader dwbitrate="241000"
dwbiterrorrate="0"
avgtimeperframe="333667">
<rcsource left="0"
top="0"
right="320"
bottom="240"/>
<rctarget left="0"
top="0"
right="320"
bottom="240"/>
<bitmapinfoheader biwidth="320"
biheight="240"
biplanes="1"
bibitcount="24"
bicompression="WMV3"
bisizeimage="0"
bixpelspermeter="0"
biypelspermeter="0"
biclrused="0"
biclrimportant="0"/>
</videoinfoheader>
</wmmediatype>
</streamconfig>
<streamconfig majortype="{73646976-0000-0010-8000-00AA00389B71}"
streamnumber="6"
streamname="Video Stream"
inputname="Video409"
bitrate="86000"
bufferwindow="5000"
reliabletransport="0"
decodercomplexity="AU"
rfc1766langid="en-us"
>
<videomediaprops maxkeyframespacing="100000000"
quality="55"/>
<wmmediatype subtype="{33564D57-0000-0010-8000-00AA00389B71}"
bfixedsizesamples="0"
btemporalcompression="1"
lsamplesize="0">
<videoinfoheader dwbitrate="86000"
dwbiterrorrate="0"
avgtimeperframe="666666">
<rcsource left="0"
top="0"
right="240"
bottom="180"/>
<rctarget left="0"
top="0"
right="240"
bottom="180"/>
<bitmapinfoheader biwidth="240"
biheight="180"
biplanes="1"
bibitcount="24"
bicompression="WMV3"
bisizeimage="0"
bixpelspermeter="0"
biypelspermeter="0"
biclrused="0"
biclrimportant="0"/>
</videoinfoheader>
</wmmediatype>
</streamconfig>
<streamconfig majortype="{73646976-0000-0010-8000-00AA00389B71}"
streamnumber="7"
streamname="Video Stream"
inputname="Video409"
bitrate="28000"
bufferwindow="5000"
reliabletransport="0"
decodercomplexity="AU"
rfc1766langid="en-us"
>
<videomediaprops maxkeyframespacing="100000000"
quality="40"/>
<wmmediatype subtype="{33564D57-0000-0010-8000-00AA00389B71}"
bfixedsizesamples="0"
btemporalcompression="1"
lsamplesize="0">
<videoinfoheader dwbitrate="28000"
dwbiterrorrate="0"
avgtimeperframe="666666">
<rcsource left="0"
top="0"
right="160"
bottom="120"/>
<rctarget left="0"
top="0"
right="160"
bottom="120"/>
<bitmapinfoheader biwidth="160"
biheight="120"
biplanes="1"
bibitcount="24"
bicompression="WMV3"
bisizeimage="0"
bixpelspermeter="0"
biypelspermeter="0"
biclrused="0"
biclrimportant="0"/>
</videoinfoheader>
</wmmediatype>
</streamconfig>
<streamconfig majortype="{73646976-0000-0010-8000-00AA00389B71}"
streamnumber="8"
streamname="Video Stream"
inputname="Video409"
bitrate="16000"
bufferwindow="5000"
reliabletransport="0"
decodercomplexity="AU"
rfc1766langid="en-us"
>
<videomediaprops maxkeyframespacing="100000000"
quality="30"/>
<wmmediatype subtype="{33564D57-0000-0010-8000-00AA00389B71}"
bfixedsizesamples="0"
btemporalcompression="1"
lsamplesize="0">
<videoinfoheader dwbitrate="16000"
dwbiterrorrate="0"
avgtimeperframe="666666">
<rcsource left="0"
top="0"
right="160"
bottom="120"/>
<rctarget left="0"
top="0"
right="160"
bottom="120"/>
<bitmapinfoheader biwidth="160"
biheight="120"
biplanes="1"
bibitcount="24"
bicompression="WMV3"
bisizeimage="0"
bixpelspermeter="0"
biypelspermeter="0"
biclrused="0"
biclrimportant="0"/>
</videoinfoheader>
</wmmediatype>
</streamconfig>
<mutualexclusion2 type="{D6E22A01-35DA-11D1-9034-00A0C90349BE}" name="">
<record name="">
<stream number="1"/>
</record>
<record name="">
<stream number="2"/>
</record>
<record name="">
<stream number="3"/>
</record>
<record name="">
<stream number="4"/>
</record>
</mutualexclusion2>
<mutualexclusion2 type="{D6E22A01-35DA-11D1-9034-00A0C90349BE}" name="">
<record name="">
<stream number="5"/>
</record>
<record name="">
<stream number="6"/>
</record>
<record name="">
<stream number="7"/>
</record>
<record name="">
<stream number="8"/>
</record>
</mutualexclusion2>
<streamprioritization>
<stream number="4" mandatory="0"/>
<stream number="8" mandatory="0"/>
<stream number="3" mandatory="0"/>
<stream number="7" mandatory="0"/>
<stream number="2" mandatory="0"/>
<stream number="6" mandatory="0"/>
<stream number="1" mandatory="0"/>
<stream number="5" mandatory="0"/>
</streamprioritization>
</profile>
]]>
</WMEncoder_Profile>

<UserData >
<WMENC_LONG Name="Encoding\Dest" Value="2" />
<WMENC_STRING Name="Encoding\Audio0" Value="{41DB0988-374A-4CB6-8929-44BAEA325D03}" />
<WMENC_STRING Name="Encoding\Video0" Value="{BB8FC6CB-4E56-474A-BC95-16DD3072AF1A}" />
<WMENC_LONG Name="Encoding\LocalComplexity" Value="-1" />
<WMENC_LONG Name="Encoding\BroadcastComplexity" Value="-1" />
<WMENC_STRING Name="Encoding\Script0" />
<WMENC_LONG Name="Encoding\Bitrate0\Video0\CustomW" Value="320" />
<WMENC_LONG Name="Encoding\Bitrate0\Video0\CustomH" Value="240" />
<WMENC_LONG Name="Encoding\Bitrate1\Video0\CustomW" Value="320" />
<WMENC_LONG Name="Encoding\Bitrate1\Video0\CustomH" Value="240" />
<WMENC_LONG Name="Encoding\Bitrate2\Video0\CustomW" Value="320" />
<WMENC_LONG Name="Encoding\Bitrate2\Video0\CustomH" Value="240" />
<WMENC_LONG Name="Encoding\Bitrate3\Video0\CustomW" Value="320" />
<WMENC_LONG Name="Encoding\Bitrate3\Video0\CustomH" Value="240" />
<WMENC_LONG Name="Encoding\Bitrate4\Video0\CustomW" Value="320" />
<WMENC_LONG Name="Encoding\Bitrate4\Video0\CustomH" Value="240" />
<WMENC_LONG Name="Encoding\Bitrate5\Video0\CustomW" Value="320" />
<WMENC_LONG Name="Encoding\Bitrate5\Video0\CustomH" Value="240" />
<WMENC_LONG Name="Encoding\Bitrate6\Video0\CustomW" Value="240" />
<WMENC_LONG Name="Encoding\Bitrate6\Video0\CustomH" Value="180" />
<WMENC_LONG Name="Encoding\Bitrate7\Video0\CustomW" Value="160" />
<WMENC_LONG Name="Encoding\Bitrate7\Video0\CustomH" Value="120" />
<WMENC_LONG Name="Encoding\Bitrate8\Video0\CustomW" Value="160" />
<WMENC_LONG Name="Encoding\Bitrate8\Video0\CustomH" Value="120" />
<WMENC_LONG Name="Encoding\Bitrate9\Video0\CustomW" Value="160" />
<WMENC_LONG Name="Encoding\Bitrate9\Video0\CustomH" Value="120" />
</UserData>

</WMEncoder>
========================END

Abacre
Site Admin
Posts: 1198
Joined: Mon Jan 31, 2005 5:32 pm
Contact:

Re: Still not working

Post by Abacre » Mon Jan 31, 2005 5:32 pm

pmaugust wrote:Roman,

I used mask *.* (and tried *.wme), but still could not make it work. Using the batch process. Below is one of the wme files and the cfg I am using. Maybe you can figure out what I don't have correct?


BTW are these files coded in Unicode or not? You may send them directly to support@abacre.com I will look it.

Guest

Post by Guest » Mon Jan 31, 2005 5:32 pm

Roman,

I just emailed you the .cfg and all 8 files I'm trying to batch update. Hopefully you can determine the error of my ways... LOL

Thanks in advance,
Paul

pmaugust

Post by pmaugust » Mon Jan 31, 2005 5:32 pm

Roman,

Was diddling with the files, and just for grins, created a new file, edited the old file with notepad, did a "select all", then a "copy", then went to the new empty file and did a "paste", and save it. Noticed in the directory list that the new file was 1/2 the size of the old file. "Hmmm..." I said to myself, and grabbed my hex file viewer. Found the original files (created as output of window media encoder process) are DBCS files, hex "00" added on to every character. The notepad copy/paste process cleaned this up and now it changes all the files.

Now just need to get the "save to a new folder" part working (see my post in the thread on that subject). I'm going to go purchase now (modifying the files is critical and that works), but making the output folder option work would be a huge benefit to me.

Regards,
Paul August

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests