Search found 1 match

by Taz35
Fri Sep 16, 2005 9:41 pm
Forum: Abacre Restaurant Point of Sale
Topic: Need Old version 1.8.0.238
Replies: 1
Views: 1945

Need Old version 1.8.0.238

Can I get the version 1.8.0.238 b/c the new version 1.9.5.384 don't work fine in win98

TIA